为了账号安全,请及时绑定邮箱和手机立即绑定

轻松学会Laravel-高级篇

难度高级
时长 1小时42分
学习人数
综合评分9.70
59人评价 查看评价
9.9 内容实用
9.6 简洁易懂
9.6 逻辑清晰
再接着上面的那个

后来百度的时候在这【https://www.cnblogs.com/baker95935/p/7668776.html】看到了这么一句“前提是检查完了
.env和config/database.php”

于是我把"config/database.php"中的配置信息改成跟.env中的一样的,就可以了​
接着上面的那个
我也卡了很久,后来折腾了一会终于有点反应了,报错如下

[Illuminate\Database\QueryException]
SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using pas
sword: NO) (SQL: select * from information_schema.tables where table_schema
= laravel_test1 and table_name = migrations)
关于前面有个问题:使用命令hp artisan migrate,没有效果,也不报错,什么都没有,无法完成迁移
注意看下端口啊,然后修改一下.env中配置什么的,然后如果有报错了,就好弄了
老师讲的好好呀,之前做项目不知道的,现在看过来真的觉得挺容易的
老师能不能照顾下win端的孩子

最新回答 / 笔尺之恋
windows 的一般是 cmd,也可以使用 git的bsh
感谢老师,让我入门laravel了
composer config -g repo.packagist
会提示
There is no packagist repository defined

正确的写法是
composer config -gl
[repositories.packagist.org.url] https://packagist.phpcomposer.com

最赞回答 / 故事的角色1757
还需要安装依赖文件,根目录下执行命令 : composer install, 但是如果PHP版本太低会报错laravel framework需要高版本的PHP,升级相应PHP版本即可!

最新回答 / 無賴
composer create-project laravel/laravel blog 5.1.*
队列这个知识点 必须要在命令行下使用么

最新回答 / 芋头丸
还是直接下载压缩包吧  

已采纳回答 / 纯洁的哥子
你换个名字试试,别用MMMModel,用个普通的,比如Student
课程须知
1、掌握《基础篇》和《表单篇》的知识 2、掌握基本的HTML相关知识 3、熟悉PHP语言,了解面向对象、命名空间、Traits等特性 4、熟悉关系型数据库Mysql,了解数据库的表、记录、列等概念。
老师告诉你能学到什么?
1、安装和使用Composer 2、使用Composer安装和管理Laravel的依赖包 3、掌握Laravel中的用户认证(Auth)、数据迁移和数据填充的使用 4、掌握文件上传、邮件、缓存、错误&日志和队列的使用

微信扫码,参与3人拼团

意见反馈 帮助中心 APP下载
官方微信
友情提示:

您好,此课程属于迁移课程,您已购买该课程,无需重复购买,感谢您对慕课网的支持!

本次提问将花费2个积分

你的积分不足,无法发表

为什么扣积分?

本次提问将花费2个积分

继续发表请点击 "确定"

为什么扣积分?

举报

0/150
提交
取消