为了账号安全,请及时绑定邮箱和手机立即绑定

通过npm安装bootstrap报错

/ 猿问

通过npm安装bootstrap报错

小甜瓜 2018-07-15 22:31:24

https://img3.mukewang.com/5b4b59c9000143e109660300.jpg

通过npm命令安装bootstrap,安装是可以成功的。通过ng serve启动服务。在通过浏览器访问4200端口后,控制台报错。 但是当移除bootstrap的引用之后,浏览器可以正常访问。

https://img3.mukewang.com/5b4b5a6a00012c8304360337.jpg

这个是angular-cli.json中的配置。望各位前端大神相助 。。。。


查看完整描述

1 回答

?
小甜瓜

该问题已经解决了:

是npm关系的问题,此外我使用的Ide webstrom的版本也从2016.1.3更新到了2017.2版本,之前在编译TypeScript的时候会报错,更新之后就没有了这个问题(升级了TypeScript的版本)。

今天早晨在StackOverflow上找到了解决方法:https://stackoverflow.com/questions/48028505/bootstrap-4-not-working-with-angular-2-app

在npm安装angular时 使用

npm install bootstrap@4.0.0-beta.2 popper.js jquery --save

依赖进行安装,在配置了angular-cli.json之后 重启ng serve之后就没有报错。如果你也遇到Bootstrap整合时候报错,希望也能帮助到你

查看完整回答
反对 回复 2018-07-16

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信