为了账号安全,请及时绑定邮箱和手机立即绑定

最新版thinkphp5.1怎么适配swoole?

/ 猿问

最新版thinkphp5.1怎么适配swoole?

之前使用5.0和某一些版本的5.1的时候,我在onWorkerStart事件里面

// 定义应用目录
define('APP_PATH', __DIR__ . '/../application/');

// 加载框架里面的文件
require __DIR__ . '/../thinkphp/base.php';


然后在onRequest事件里面

ob_start();
think\Container::get('app')->run()->send();
$res = ob_get_contents();
ob_end_clean();
$response->end($res);



现在最新版的thinkphp5.1没有了start.php,执行应用放在index.php,而且index.php里面没有定义常量了。

我便在onWorkerStart事件里面

// 加载框架里面的文件
require __DIR__ . '/../thinkphp/base.php';



然后onRequest事件的代码不变,结果报错了。

https://img3.mukewang.com/5c6794b20001e9a708560133.jpg

我尝试在ob_clean()前面加上@,结果变成了在命令行终端输出了2遍index方法里面的内容,浏览器没有输出。



请问一下,我要怎么修改啊????

查看完整描述

目前暂无任何回答

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信