为了账号安全,请及时绑定邮箱和手机立即绑定

如何在CentOS上搭建ruby on rails环境

/ 猿问

如何在CentOS上搭建ruby on rails环境

HUWWW 2019-03-03 08:08:04

如何在CentOS上搭建ruby on rails环境


查看完整描述

3 回答

?
四季花海

1、进入Centos6.4系统。

2、查看CentOS6.4的网络环境。
◆使用ping命令测试网络环境。若如下图有返回则网络环境正常。
说明:因为是在线安装,故此必须保证网络环境正常,其能连接到互联网。
注:使用Ctrl + c 可结束ping命令

3、安装rvm。
◆输入命令:curl -sSL https://get.rvm.io | bash -s stable
说明:[-sSL]中最后两个字必须为大写,或全部为大写;否则会出错。
注:rvm 全称Ruby Version Manager,是一个非常好ruby版本管理和安装工具。

4、查看rvm安装是否成功。
◆输入命令:rvm -v,查看rvm版本,如下图则安装成功。

5、安装ruby。
◆输入命令:rvm install 1.9.3或rvm install ruby-1.9.3或rvm install ruby-1.9.3-p547,这三种方式都6、可安装ruby的1.9.3版本(示例:1.9.3版本)。
◆Rvm命令简单使用介绍:
rvm install ruby 默认安装最新版本
rvm reinstall ruby 重新安装
rvm remove ruby 删除ruby的安装
7、若需安装、重装、删除ruby都可指定版本,即在ruby后面写上相应参数。
注:安装过程可能出现异常,这可能是由于网络原因,需多尝试几次。

查看ruby安装是否成功。
◆输入命令:ruby -v 查看ruby版本,如下图则安装成功。
◆输入ruby -e 'p "hello ruby"' 可测试ruby(可略)。

8、使用gem安装rails。
◆输入命令:gem install rails,默认安装最新版本rails。
◆可安装指定版本的rails,比如:gem install rails -v 3.2.13。
注:安装过程可能出现异常,这可能是由于网络原因,需多尝试几次。

查看rails安装是否成功。
◆输入命令:rails -v 查看rails版本,如下图则安装成功。
当ruby、rails环境安装完成即完成了CentOS上搭建ruby on rails环境。



查看完整回答
反对 回复 2019-03-14
?
慕的地8271018

yum -y install libxslt-devel libyaml-devel libxml2-devel gdbm-devel libffi-devel zlib-devel \
openssl-devel libyaml-devel readline-devel curl-devel openssl-devel pcre-devel git memcached-devel \
valgrind-devel mysql-devel ImageMagick-devel ImageMagick gcc gcc-c++ libstdc++-devel
yum -y install gcc gcc-c++ libstdc++-devel autoconf automake

cd /usr/local/src
wget https://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.3.tar.gz
tar zxf ruby-2.2.3.tar.gz
cd ruby-2.2.3
./configure --prefix=/usr/local/ruby
make
make install

cat<<EOF>>/etc/profile
RUBY_HOME=/usr/local/ruby
PATH=$PATH:/usr/local/ruby/bin
EOF

source /etc/profile
export RUBY_HOME PATH

ruby -v

cd /usr/local/src
wget https://rubygems.global.ssl.fastly.net/rubygems/rubygems-2.4.8.zip
unzip rubygems-2.4.8.zip
cd rubygems-2.4.8
ruby setup.rb

gem install rails -r -y
rails -v

 


查看完整回答
反对 回复 2019-03-14
?
慕娘9325324

cd /usr/local/src

wget https://rubygems.global.ssl.fastly.net/rubygems/rubygems-2.4.8.zip
unzip rubygems-2.4.8.zip
cd rubygems-2.4.8
ruby setup.rb
gem -v

gem install rails -r -y
rails -v

查看完整回答
反对 回复 2019-03-14
  • 3 回答
  • 0 关注
  • 205 浏览
我要回答

相关问题推荐

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信