为了账号安全,请及时绑定邮箱和手机立即绑定

请问一下Mac python3.7.1怎么降低到3.6版本?

/ 猿问

请问一下Mac python3.7.1怎么降低到3.6版本?

MMTTMM 2019-10-14 14:10:07

Mac python3.7.1怎么降低到3.6版本


查看完整描述

4 回答

?
米琪卡哇伊

mac 上面有一个 homebrew 工具。提供各式各样的开发环境,并且可以在不同版本的环境之间切换。这样的好处是不管你怎么折腾,都不会污染到系统原生的环境。同样的,系统如果升级以后也不会影响到你的开发环境。

1. 安装 Homebrew

1/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2. 安装 python

1brew install python

brew 默认安装的是 python 最新版本。可以用如下命令查看:

1brew info python

3. 安装 python 3.6

首先解除 python 绑定的 3.7 版本

1brew unlink python

接下来安装指定版本的 python

1brew install --ignore-dependencies https://raw.githubusercontent.com/Homebrew/homebrew-core/f2a764ef944b1080be64bd88dca9a1d80130c558/Formula/python.rb

再次 用 brew info python 查看 python 版本,可以看见这个时候 python 关联的是 3.6.5

4. 使用 brew switch 在不同版本的 python 间切换

假设你 homebrew 上面安装的 python 版本是 3.7.2 和 3.6.5_1,则可以在这两个版本间切换

12brew switch python 3.7.2brew switch python 3.6.5_1



查看完整回答
反对 回复 2019-10-26
?
DIEA

不建议修改默认版本,系统中可能有依赖默认python版本的软件
开发是选择你需要的版本即可
应该是可以在IDE里选择的
vscode没试过,你可以试试pycharm

查看完整回答
反对 回复 2019-10-26
?
Qyouu

苹果电脑双系统切换: 在电脑开机或重启时,按着“option”键不松手。(详细请看下图) 进入引导界面,有“Macintosh HD”和“windows”两个选项,进入Mac系统,用方向键选中“Macintosh HD”,回车即可进入。

查看完整回答
反对 回复 2019-10-26
?
天涯尽头无女友

MySQLdb不支持Python3的版本呦,要是想使用MySQL的话,最好安装mysqlclient1.3.3版本以上,而且mysqlclient不支持python3.2,最好使用python3.3以上的版本。

查看完整回答
反对 回复 2019-10-26

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信