为了账号安全,请及时绑定邮箱和手机立即绑定

我该如何解决npm UNMET PEER DEPENDENCY警告?

/ 猿问

我该如何解决npm UNMET PEER DEPENDENCY警告?

我在Windows 10上,使用Node 5.6.0和npm 3.6.0。我正在尝试将angular-material和mdi安装到我的工作文件夹中。npm使用以下命令安装角度材料的mdi错误:


+-- angular@1.5.0


+-- UNMET PEER DEPENDENCY angular-animate@^1.5.0


+-- UNMET PEER DEPENDENCY angular-aria@^1.5.0


+-- angular-material@1.0.6


+-- UNMET PEER DEPENDENCY angular-messages@^1.5.0 `-- mdi@1.4.57


npm WARN enoent ENOENT: no such file or directory, open

'C:\Users\xxxxx\Desktop\ngClassifieds\package.json' 


npm WARN angular-material@1.0.6 requires a peer of

angular-animate@^1.5.0 but none was installed. 


npm WARN angular-material@1.0.6 requires a peer of angular-aria@^1.5.0

but none was installed. 


npm WARN angular-material@1.0.6 requires a peer of

angular-messages@^1.5.0 but none was installed.

如何解决此问题以安装AngularJS材质和MDI?


查看完整描述

3 回答

?
FFIVE

npm不再安装对等依赖项,因此您需要手动安装它们,只需npm install对所需的deps进行安装,然后尝试再次安装主要的依赖项。


回复评论:


这是正确的信息,它说明您缺少哪些部门


UNMET PEER DEPENDENCY angular-animate@^1.5.0 +-- 

UNMET PEER DEPENDENCY angular-aria@^1.5.0 +-- angular-material@1.0.6 +

UNMET PEER DEPENDENCY angular-messages@^1.5.0 `-- mdi@1.4.57` 

所以你需要 npm install angular angular-animate angular-aria angular-material angular-messages mdi


查看完整回答
反对 回复 2019-11-07
?
慕仰8121524

UNMET PEER DEPENDENCY当package.json不满足文件中指定的一个或多个模块的依赖性时,将引发错误。仔细检查警告,并package.json使用正确版本的依赖项更新文件。


然后跑


rm -rf node_modules/

npm cache clean

npm install

这将正确安装所有必需的依赖项。


查看完整回答
反对 回复 2019-11-07
?
慕丝7291255

好的,所以我努力了很长时间试图解决这个问题。这是选项,适用于您用尽其他所有方式后。

  • 在您的PC上新建一个文件夹。

  • 下载全新的angular安装-我使用了本指南:https://coursetro.com/posts/code/55/How-to-Install-an-Angular-4-App

  • 运行它,确保它能正常工作

  • 然后从package.json文件中一一安装您的依赖关系

  • 每个安装后运行它

完成后,它仍然有效,将实际代码导入到这个新项目中。修正新的角度原因导致的编译错误。

那就是为我做的.. 1个小时的返工vs 6个小时的尝试找出wtf是错误的..希望我以此方式开始。


查看完整回答
反对 回复 2019-11-07

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信