为了账号安全,请及时绑定邮箱和手机立即绑定
首页 手记 caffe-windows版本环境配置相关问题

caffe-windows版本环境配置相关问题

2018.11.29 11:41 2298浏览

作者:会写代码的好厨师

链接:https://www.imooc.com/article/275499
来源:慕课网

对于caffe的配置安装一直都是新手刚开始接触caffe是遇到的最大的困难。这里简单的谈一谈windows版本的安装。

1)准备工作

源码下载:caffe版本Microsoft/caffe

环境安装:cuda9.0:CUDA Toolkit 9.0 Downloads,主要是版本不要出问题

cudnn: cudnn-9.0-windows10-x64-v7.1

python2.7,建议用python2,不建议用conda

VS2013


2)打开VS2013,使用VS2013打开caffe,里面有一个VS的工程项目。

3)在VS里面找到,更新Nuget程序包管理,需要修改opencv版本,还可能会有一些其他库版本的更新,一并处理掉。

4)math_functions函数编码错误,打开在保存就OK了

5)python版本最好使用python2

6)errorMSB3721:too few arguments in function call

修改文件cudnn.hpp


<img src="https://pic2.zhimg.com/v2-edbf296636b6f3c7fb4a77d0c1358511_b.jpg" data-caption="" data-size="normal" data-rawwidth="983" data-rawheight="353" class="origin_image zh-lightbox-thumb" width="983" data-original="https://pic2.zhimg.com/v2-edbf296636b6f3c7fb4a77d0c1358511_r.jpg">5bff5e500001e6df07200259.jpg


7)python27_d文件问题

缺少Python27_d.lib的解决方法

另外,可能还需要配合一个网上的教程,告诉大家具体的步骤,这里主要是谈到编译过程会遇到的bug。希望能够对大家有用~








点击查看更多内容

本文原创发布于慕课网 ,转载请注明出处,谢谢合作

2人点赞

若觉得本文不错,就分享一下吧!

评论

相关文章推荐

正在加载中
意见反馈 帮助中心 APP下载
官方微信

举报

0/150
提交
取消