为了账号安全,请及时绑定邮箱和手机立即绑定

wordpress在裁剪您的图像时发生了错误。

2019.08.17 14:18 102浏览

CentOS + Nginx :

缺少PHP GD库,一般只需要安装gd库 yum install php-gd重启 Nginx 即可 。


  Error: php71w-common conflicts with php-common-5.3.3-49.el6.x86_64 

一般以上就能解决,但若安装时出现类似出错,则必须要指定版本安装: yum install php71w-gd 。安装完gd库后,配置一哈:

rpm -qal | grep gd.so 查找go.so所在位置 gd.so( 比如我的 ↓

 [root ~]# rpm -qal | grep gd.so
 /usr/lib/libgd.so.2 
 /usr/lib/libgd.so.2.0.0 
 /usr/lib/php-zts/modules/gd.so (← 看gd.so所在的第一个路径!)
 /usr/lib/php/modules/gd.so 

rpm -qal | grep php.ini 查找 php.ini 所在位置, 修改配置 。建议用 Xftp 下载下来用 Notepad++ 之类的改,这文件好长的,记事本和vim实在是太难找了(;´д`)ゞ 搜索 [gd] 所在位置, 在这段最后面加上一个 extension= 上面gd.so 的位置 ( 比如我的 ↓

 [gd] 
 ; Tell the jpeg decode to ignore warnings and try to create 
 ; a gd image. The warning will then be displayed as notices
 ; disabled by default
 ; http://php.net/gd.jpeg-ignore-warning
 ; gd.jpeg_ignore_warning = 0
 ; extension = /usr/lib/php-zts/modules/gd.so  ( ← 新加的 )

保存完最后重启 php-fpm 就完事了(๑•̀ㅂ•́)و✧ service php-fpm restart

点击查看更多内容
0人点赞

若觉得本文不错,就分享一下吧!

评论

相关文章推荐

正在加载中
意见反馈 邀请有奖 帮助中心 APP下载
官方微信

举报

0/150
提交
取消