为了账号安全,请及时绑定邮箱和手机立即绑定

Android Compose编译错误

2021.03.31 21:57 269浏览

Compose是声明式UI,目前处于预览阶段,在项目编译阶段会出现编译不通过的现象,主要表现为提示以下错误:

An exception occurred applying plugin request [id: 'com.android.application']

其实主要原因是项目gradle文件中classpath默认引用的gradle版本是7.0,而7.0的gradle需要JDK11才能正常编译,所以解决这个问题有两种方式:

  1. 下载并安装JDK11,并且设置项目的JDK路径为JDK11的目录。
  2. 不用下载JDK11,直接把项目JDK路径改为预览版本。

image.png

然后重新编译即可

点击查看更多内容
0人点赞

若觉得本文不错,就分享一下吧!

评论

相关文章推荐

正在加载中
意见反馈 帮助中心 APP下载
官方微信

举报

0/150
提交
取消