为了账号安全,请及时绑定邮箱和手机立即绑定

0到1快速构建自己的后台管理系统

沁尘 全栈工程师
难度入门
时长 4小时32分
学习人数
综合评分9.47
13人评价 查看评价
9.4 内容实用
9.5 简洁易懂
9.5 逻辑清晰

已采纳回答 / 沁尘
分类信息一般都是需要持久化的,也就说如果出现这种情况,去数据库添加字段是少不了的了。改完之后,很多业务代码都得改,所以一般在开发之前,数据库表设计需要充分斟酌。当然在现实开发中,业务系统运行了一段时间之后,突然加字段也是可能会发生的,所以这种情况其实在业务代码开发的时候也要考虑到,解决办法就是代码架构分层,尽量把变化隔离在某一层,让上层调用不受影响,把变化影响的范围尽可能缩小。比如我们课程中就尝试过在 service 层做数据字段处理来兼容业务逻辑。当然,现实中情况会更加复杂,但是思路是一样的。

最赞回答 / 慕慕4138228
已解决,5000端口被占用,app/config/setting.js修改port端口号即可

讲师回答 / 沁尘
框架默认启用了“软删除”机制。你可以看看你的delete_time字段,上面会有个时间戳,如果你把这个字段的值置空,你就会发现又查询到了。一般业务表,多数都采用软删除机制,即——逻辑上不可见,但实际记录还是存在于数据库中的。所以软删除也叫逻辑删除,与之对应的就是物理删除。逻辑删除和物理删除的场景和概念同学可以百度查询下资料,有很多,这里就不再赘述。如果同学想阅读相关资料的过程中有什么疑问可以提出。

讲师回答 / 沁尘
框架有个依赖的版本太低,在node 14上有问题。解决办法有2个:1、降node版本,亲测12.20可以正常。(个人觉得不用担心12这个版本会不会太低,绝大多数应用都没问题)2、等官方调高依赖版本

讲师回答 / 沁尘
以往这种问题是因为前后端版本不匹配导致的,同学你按照视频的步骤来的话是不会出现这种问题的,你可以描述下你操作的步骤,包括执行的命令

讲师回答 / 沁尘
框架有个依赖的版本太低,在node 14上有问题。解决办法有2个:1、降node版本,亲测12.20可以正常。(个人觉得不用担心12这个版本会不会太低,绝大多数应用都没问题)2、等官方调高依赖版本

讲师回答 / 沁尘
第一张图没看出来有啥错误。第二张图,我在2-1小节有提醒了,这是ES-lint的语法警告,因为Mac和Windows的换行符不一致导致的,上面的提示同学你用软件翻译下就知道了,这个错误是可以忽略的。

讲师回答 / 沁尘
看提示像是权限不足,你这里使用管理员身份运行命令行,然后再操作。操作前先删除lin-cms-vue目录下的node_modules目录

讲师回答 / 沁尘
具体是啥操作,可以贴下代码,让我更清楚的了解你的需求

讲师回答 / 沁尘
同学你好,我这边没有复现你这个问题。你可以尝试排查下问题。F12打开浏览器的控制台,看看修改这次提交的表单参数内容是不是正确的。如果发现参数还是原来旧的,那说明前端代码有问题。如果提交的参数内容确实是新的,那么就是后端的代码出了问题。评论区有同学完成了课程内容并发布在了GitHub上,可以看看对照检查下代码。

讲师回答 / 沁尘
第一张图里提示了,movie模型里第17行有错误。看看是不是拼写错误或者没有引入类库

讲师回答 / 沁尘
上次帮另一个同学远程解决了这个问题,貌似确实是源码这块有问题,感谢同学分享

已采纳回答 / 沁尘
lin-cms-koa 中日志查询接口就是分页查询示例。位于app/api/cms/log.js分页查询前端也需要做相应的适配可在lin-cms-vue中查看相关的代码抄一遍就会了
首页上一页12345下一页尾页
课程须知
1、有简单的koa项目开发经验 2、有简单的Vue 项目开发经验
老师告诉你能学到什么?
1、快速搭建一个运营数据管理的后台管理系统 2、复用实现思路,个性开发自己的业务功能模块

微信扫码,参与3人拼团

意见反馈 帮助中心 APP下载
官方微信
友情提示:

您好,此课程属于迁移课程,您已购买该课程,无需重复购买,感谢您对慕课网的支持!

本次提问将花费2个积分

你的积分不足,无法发表

为什么扣积分?

本次提问将花费2个积分

继续发表请点击 "确定"

为什么扣积分?

举报

0/150
提交
取消