为了账号安全,请及时绑定邮箱和手机立即绑定
关注
沐寒528

安装cli出错

在命令行显示了node  npm  版本号后安装cli出错如下 fetchMetadata: sill fetchPackageMetaData error for lodash.clonedeep@^4.5.0 Unexpected end of JSON input while parsing near '...:{"name":"lodash.clon' 请问该如何操作呢

2020-03-15 源自:vue2.5入门 4-1 210 浏览 2 回答

最佳回答

2020-03-17

我们通过npm命令下载node模块的时候因为访问的是国外网站,所以可能会出现下载的很缓慢或者干脆是直接下载失败,在这种情况下,我们可以通过配置国内镜像来解决,一般配置的是淘宝npm镜像

1.通过以下命令配置淘宝镜像

npm install -g cnpm --registry=https://registry.npm.taobao.org
2.以后下载模块的时候,将npm替换成cnpm即可从淘宝镜像中下载模块,例如

cnpm install

你那个不是出错,是下载卡住了,配置过淘宝镜像以后就下载快了

这个确实快多了,我安装了1小时都没成功。老师应该在课程中说到这个事情,据然一个字没提,不过教程讲的不错

2020-05-31
0

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信