为了账号安全,请及时绑定邮箱和手机立即绑定

Failed to load external module @babel/register;

/ 猿问

Failed to load external module @babel/register;

weixin_小金_1 2018-01-13 16:27:05

http://img3.mukewang.com/5a59c1df00010f3805170340.jpg

已经npm install babel-register,还是出错

查看完整描述

11 回答

?
慕斯2206749

请问下楼主解决了吗?

查看完整回答
1 反对 回复 2018-06-13
?
nfwater

检查了下还是,包的版本问题,替换下包:

"babel-core": "^6.24.0",
"babel-loader": "^6.4.1",
"babel-plugin-transform-decorators-legacy": "^1.3.4",
"babel-polyfill": "^6.23.0",
"babel-preset-env": "^1.2.2",
"babel-preset-es2015": "^6.24.0",
"connect-livereload": "^0.6.0",
"del": "^2.2.2",
"gulp": "^3.9.1",
"gulp-concat": "^2.6.1",
"gulp-if": "^2.0.2",
"gulp-live-server": "0.0.30",
"gulp-livereload": "^3.8.1",
"gulp-plumber": "^1.1.0",
"gulp-rename": "^1.2.2",
"gulp-sequence": "^0.4.6",
"gulp-uglify": "^2.1.0",
"gulp-util": "^3.0.8",
"jquery": "^3.2.1",
"require-dir": "^0.3.1",
"vinyl-named": "^1.1.0",
"webpack": "^2.2.1",
"webpack-stream": "^3.2.0",
"yargs": "^7.0.2"


查看完整回答
反对 回复 2019-11-29
?
杨先生要努力了

"gulp": "^3.9.0",

我直接修改的package.json的版本

查看完整回答
反对 回复 2019-04-28
?
慕瓜8559766

https://img1.mukewang.com/5ca75acf000133b204980362.jpg

其实和那个包没有关系,视频作者并没有这个包

我是这样做的先去把server里的依赖先都下载好了,可以先不要在外面gulp启动服务,先直接在server里面启动express,启动好了之后可以再去tasks目录下的server.js里面去

https://img.mukewang.com/5ca75b5500019b1002930106.jpg

注释掉这一段,应该是这段代码return掉了下面的服务启动,之后就可以启动了。

其实包的版本有很多的坑,所以大家最好按照视频作者的版本安装。

查看完整回答
反对 回复 2019-04-05
?
houyusi

npm i -g gulp@3.9.0

降到下一个版本的gulp就好啦

查看完整回答
2 反对 回复 2018-06-23
?
isu_腾飞
# 目前版本3.9.1 会报这个错误,删除新的版本,安装旧版本就可以了
sudo rm -rf /usr/local/lib/node_modules/gulp   
sudo cnpm i -g gulp@3.9.0


查看完整回答
2 反对 回复 2018-03-31
?
qq_碧海波心_0

无法访问页面,怎么办

查看完整回答
反对 回复 2018-02-21
?
幕木_

pakege.json到依赖发出来看看呢

查看完整回答
反对 回复 2018-01-15
?
weixin_小金_1

//babel.rc

{

  "presets":["es2015"]

}


查看完整回答
反对 回复 2018-01-15
?
qq_冰雪鹰然_0

你后来怎么解决的

查看完整回答
反对 回复 2018-01-14
  • weixin_小金_1
    weixin_小金_1
    还没有解决
  • qq_冰雪鹰然_0
    qq_冰雪鹰然_0
    我解决了,把gulp降到3.9.0版本就好了
  • qq_碧海波心_0
    qq_碧海波心_0
    降低了gulp版本,出现这个问题 [19:59:42]Failed to load external module @babel/register [19:59:42] Requiring external module babel-register [19:59:42] Warning: gulp version mismatch: [19:59:42] Global gulp is 3.9.1 [19:59:42] Local gulp is 3.9.0
点击展开后面3
?
幕木_

babel.rc配置发来看下

查看完整回答
反对 回复 2018-01-13

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信