为了账号安全,请及时绑定邮箱和手机立即绑定

package.json 被不小心删除了,求源码

/ 猿问

package.json 被不小心删除了,求源码

Tony_Lau 2018-01-28 19:47:40
查看完整描述

5 回答

?
慕粉1027077197

在控制台输入:npm init -y       

然后看下你的文件目录 之前用的package.json就回来了




只是有个问题:所有的依赖跑到开发版里去了,需要复制到发布版

查看完整回答
反对 回复 2019-08-15
?
weixin_999_0

???????????????????????

查看完整回答
反对 回复 2018-01-29
?
underfineded

-loader": "^0.6.2",

"webpack": "^3.10.0",

"webpack-dev-server": "^2.11.1"

},

"dependencies": {

"css-loader": "^0.28.9",

"vue": "^2.5.13",

"vue-loader": "^13.7.0",

"vue-template-compiler": "^2.5.13"

}

}

查看完整回答
反对 回复 2018-01-28
?
underfineded

{

"name": "vuedemo",

"version": "1.0.0",

"description": "vue todolist",

"main": "index.js",

"scripts": {

"test": "echo \"Error: no test specified\" && exit 1",

"build": "cross-env NODE_ENV=production webpack --config webpack.config.js",

"dev": "cross-env NODE_ENV=development webpack-dev-server --config webpack.config.js"

},

"repository": {

"type": "git",

"url":""

},

"author": "",

"license": "ISC",

"devDependencies": {

"autoprefixer": "7.2.3",

"babel-core": "6.26.0",

"babel-helper-vue-jsx-merge-props": "2.0.3",

"babel-loader": "7.1.2",

"babel-plugin-syntax-jsx": "6.18.0",

"babel-plugin-transform-vue-jsx": "3.5.0",

"babel-preset-env": "1.6.1",

"cross-env": "5.1.3",

"css-loader": "0.28.7",

"extract-text-webpack-plugin": "3.0.2",

"file-loader": "^1.1.6",

"html-webpack-plugin": "2.30.1",

"postcss-loader": "^2.0.10",

"style-loader": "^0.19.1",

"stylus": "0.54.5",

"stylus-loader": "3.0.1",

"ur

查看完整回答
反对 回复 2018-01-28
?
拖鞋_

找个空文件夹

执行  vue init  webpack  aaa

然后进入aaa这个文件夹 复制package.json过去就行了


前提是你装了node  webpack  vue-cli

如果没装node  请百度下载一下

(这里建议装一下cnpm 国内你懂的没办法)

没装webpack  请在下载完node后  执行 cnpm i webpack -g

没装vue-cle 执行  cnpm i vue-cli -g

就好了

查看完整回答
反对 回复 2018-01-28

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信