为了账号安全,请及时绑定邮箱和手机立即绑定

vux 安装失败NMET PEER DEPENDENCY less@3.0.0-alpha.3

vux 安装失败NMET PEER DEPENDENCY less@3.0.0-alpha.3

慕哥9229398 2018-08-14 16:11:23

https://img1.sycdn.imooc.com/5b7c12660001df7d08000182.jpg

然后我就npm install --save vux 但是也没用
https://img2.sycdn.imooc.com/5b7c127700011bc105020146.jpg

之后我就npm install -g less
下载成功之后一样报了这个错误
UNMET PEER DEPENDENCY less@3.0.0-alpha.3

求大神指导下!!!


查看完整描述

2 回答

?
jeck猫

TA贡献1840条经验 获得超9个赞

第一个报错是组件名写错了,找不到对应的组件地址。
第二个并不是报错,只是依赖里有某个模块要求 less 大于某版本而已,应该并不影响使用。

查看完整回答
反对 回复 2018-08-21
?
达令说

TA贡献1778条经验 获得超7个赞

我前段时间刚解决了这个问题,向1楼说的那样改变less的版本就可以!
用npm install --save-dev less@2.7.2(我安装的是这个版本)
npm install --save-dev less-loader@4.0.5(我安装的是这个版本)

希望可以解决你的问题


查看完整回答
反对 回复 2018-08-21

添加回答

回复

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信