为了账号安全,请及时绑定邮箱和手机立即绑定

请教一个composer安装swoole_mqtt_client问题?

/ 猿问

请教一个composer安装swoole_mqtt_client问题?

元芳怎么了 2018-10-28 14:11:43

swoole-mqtt-client (by:https://github.com/w3yyb/swoole-mqtt-client
我通过composer require jesusslim/mqttclient 安装的时候提示了我下列错误:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for jesusslim/mqttclient ^1.3 -> satisfiable by jesusslim/mqttclient[1.3].
- jesusslim/mqttclient 1.3 requires jesusslim/pinject dev-master -> satisfiable by jesusslim/pinject[dev-master] but these conflict with your requirements or minimum-stability.

Installation failed, reverting ./composer.json to its original content.

然后我通过composer require jesusslim/pinject 已经安装了 jesusslim/pinject,但是我再回过来安装composer require jesusslim/mqttclient 依然提示上述错误,能告诉我需要怎么解决吗?

查看完整描述

1 回答

?
慕少森

修改 composer.json 加入 "jesusslim/pinject"=>1.3
composer.phar update
这样应该就可以了

查看完整回答
反对 回复 2018-11-15

添加回答

回复

举报

0/150
提交
取消
意见反馈 邀请有奖 帮助中心 APP下载
官方微信