为了账号安全,请及时绑定邮箱和手机立即绑定

webpack4配置设计babel的问题

/ 猿问

webpack4配置设计babel的问题

如题。安装了

"babel-core": "^6.26.3",

"babel-loader": "^8.0.4",

"babel-plugin-transform-runtime": "^6.23.0",

"babel-preset-env": "^1.7.0",

"babel-preset-stage-0": "^6.24.1",

运行报错:

Cannot find module '@babel/core'

 babel-loader@8 requires Babel 7.x (the package '@babel/core'). If you'd like to use Babel 6.x ('babel-core'), you should install 'babel-loader@7'.

请问,这个问题怎么解决啊

查看完整描述

2 回答

?
八神光

安装7.x版本的babel-loader或者安装7.x版本的babel-core

报错里告诉你了 8.x版本的babel-loader配7.x版本的babel-core,而7.x版本的babel-loader配6.x版本的babel-core

查看完整回答
2 反对 回复 2018-12-26
点击展开后面1
?
_Bling_

注意:@babel/core,现在安装新版babel时貌似都要这样写,而不是babel-core。应该时这样可以试下。

查看完整回答
反对 回复 2018-12-26

添加回答

回复

举报

0/150
提交
取消
意见反馈 邀请有奖 帮助中心 APP下载
官方微信