为了账号安全,请及时绑定邮箱和手机立即绑定

变量命名的问题:叫 btnAdd 还是 addBtn 呢?

变量命名的问题:叫 btnAdd 还是 addBtn 呢?

杨__羊羊 2019-03-02 09:34:19
首先限定为:驼峰命名法。虽然叫什么都可以,但是还是有个规范比较好。想听听大家的看法,或者推荐一下这方面的规范。add是说明 button 功能的,如果再加一个描述 button 的词 small 呢?btnAddSmall?btnSmallAdd?smallAddBtn?addSmallBtn?addBtnSmall?smallBtnAdd?
查看完整描述

2 回答

?
千万里不及你

TA贡献1784条经验 获得超9个赞

一般来说变量应该是个名词,比如 btn。后面还可以加状语,比如 btnAdded,表按钮已经完成了添加动作。

但 btnAdd,给我的感觉就是,不知道这个按钮正处于什么时刻,对即将发生些什么,不是那么明确。


查看完整回答
反对 回复 2019-03-02
?
SMILET

TA贡献1796条经验 获得超4个赞

应该都可以,平时开发的时候我也是两种都会用。
第一种是把名词前置,不符合自然语言的表达习惯,但好处是有利于代码的整齐和代码提示。

第二种跟自然语言一致,但缺点正好是第一种的优点。


查看完整回答
反对 回复 2019-03-02
  • 2 回答
  • 0 关注
  • 587 浏览

添加回答

举报

0/150
提交
取消
微信客服

购课补贴
联系客服咨询优惠详情

帮助反馈 APP下载

慕课网APP
您的移动学习伙伴

公众号

扫描二维码
关注慕课网微信公众号