为了账号安全,请及时绑定邮箱和手机立即绑定

Eclipse错误:从所需的.class文件间接引用?

/ 猿问

Eclipse错误:从所需的.class文件间接引用?

墨色风雨 2019-09-21 15:48:38

我在Eclipse中出错。此错误消息是什么意思:


The type iglu.ir.TermVector cannot be resolved. It is indirectly referenced from required .class files


查看完整描述

3 回答

?
隔江千里

这意味着:“您使用的类需要另一个不在类路径上的类。” 您应该确保(如Harry Joy所建议的那样)将所需的jar添加到类路径中。


查看完整回答
反对 回复 2019-09-21
?
一只甜甜圈

这很可能是Eclipse感到困惑的原因,因为它是一个实际错误。我忽略了该错误,并运行了Web服务,它抱怨了它的endpointInterface,并且运行良好,只是每次我想运行它时都必须处理对话框。另一个不透明的错误告诉我什么。


查看完整回答
反对 回复 2019-09-21
?
慕码人8056858

听起来这是一个已知问题(错误67414),已在3.0中解决。...有人评论说,在3.4中也存在此问题。


同时,解决方法是从项目中删除JRE系统库,然后再次将其重新添加。


Here are the steps:

转到带有构建错误的项目属性(右键单击>属性)


查看“构建路径”部分中的“库”选项卡


在列表中找到“ JRE系统库”(如果缺少此消息,则此错误消息不是Eclipse错误,而是配置错误的项目)


删除“ JRE系统库”


点击“添加库...”,选择“ JRE系统库”并为项目添加适当的JRE(例如,“工作区默认JRE”)


在库选择中单击“完成”,在项目属性中单击“确定”,然后等待重新生成项目


希望错误会得到解决...


查看完整回答
反对 回复 2019-09-21

添加回答

回复

举报

0/150
提交
取消
意见反馈 邀请有奖 帮助中心 APP下载
官方微信