为了账号安全,请及时绑定邮箱和手机立即绑定

无法使用 VS 代码运行/编译 Java 程序

无法使用 VS 代码运行/编译 Java 程序

小怪兽爱吃肉 2022-09-22 16:34:41

当我点击f5时,我在调试窗口中得到这个文本


Error: LinkageError occurred while loading main class Hello

    java.lang.UnsupportedClassVersionError: Hello (class file version 52.65535) was compiled with preview features that are unsupported. This version of the Java Runtime only recognizes preview features for class file version 56.65535

爪哇 -版本显示


javac 12

爪哇 -版本


openjdk version "12" 2019-03-19

OpenJDK Runtime Environment AdoptOpenJDK (build 12+33)

OpenJDK 64-Bit Server VM AdoptOpenJDK (build 12+33, mixed mode, sharing)

我正在尝试编译的代码


public class Hello {

    public static void main(String[] agrs)

    {

        System.out.println("Hello world!");

    }

}

正确设置了路径、JAVA_HOME和JRE_HOME。已安装调试加载项。我可以在 InteliJ IDEA 或使用 java(文件),javac(文件)编译和运行相同的代码,它可以正常工作,但我不知道为什么它不适用于 vscode。


查看完整描述

1 回答

?
千巷猫影

TA贡献1466条经验 获得超7个赞

发送指向其他问题的链接,它帮助链接到问题

总结:

  1. 确保卸载 jdk8 干净

  2. 安装 jdk11

  3. 在启动.json 中添加“vmArgs”:“--启用预览”

  4. F1, “爪哇: 干净 ...”和“爪哇:力......”

  5. 再次运行独立文件


查看完整回答
反对 回复 2022-09-22

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信