为了账号安全,请及时绑定邮箱和手机立即绑定

如果我有 go 版本 1.7,我怎么知道我使用的是哪个未成年人?

如果我有 go 版本 1.7,我怎么知道我使用的是哪个未成年人?

Go
Qyouu 2022-11-23 14:00:38

我对 GO 一无所知,我从未使用过它。但是我帮助过一个团队,他们需要更新他们的项目。


最近发现了一个错误,他们必须将 go 的版本更新到 1.17.8,但在 go.mod 中我看到他们使用的是 1.17。


如果我输入 1.17.8 我会收到格式错误,因为它必须是 XX 而不能是 XXX,我怎么知道我使用的是哪个版本的 minior?或者我如何确定我使用的是正确的版本。


go 1.17.8  //Compile Error -> go version '1.17.8': must match format 1.23 (I NEED THIS ONE)

go 1.17  //Compile OK


查看完整描述

1 回答

?
哈士奇WWW

TA贡献1517条经验 获得超1个赞

[H]我怎么能确定我使用的是正确的版本。

通过安装正确的版本。go.mod 中的 go 指令对您的安装没有影响。


查看完整回答
反对 回复 5天前

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信