为了账号安全,请及时绑定邮箱和手机立即绑定

大家好,我的makelists.txt里面需要找到wxWidgets,该怎么做呢?

大家好,我的makelists.txt里面需要找到wxWidgets,该怎么做呢?

SMILET 2023-01-07 18:14:28

set (wxWidgets_USE_LIBS base core)
FIND_PACKAGE(wxWidgets COMPONENTS core base REQUIRED)
include (${wxWidgets_USE_FILE})

cmake 输出结果:

$ cmake -G "MSYS Makefiles"
CMake Error at c:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
Could NOT find wxWidgets (missing: wxWidgets_FOUND)
Call Stack (most recent call first):
c:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
c:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindwxWidgets.cmake:831 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:8 (FIND_PACKAGE)

-- Configuring incomplete, errors occurred!

请问为什么,我安装了wxWidgets 在C:\wxWidgets-2.9.1,但它还是找不到。在网上找了好久,没有答案。请高手帮忙,多谢了!

查看完整描述

1 回答

?
HUWWW

TA贡献1622条经验 获得超11个赞

sudo apt-get install subversion build-essential cmake gettext
sudo apt-get install libwxgtk2.8-dev libtagc0-dev libsqlite3-dev libcurl4-gnutls-dev libdbus-1-dev libgstreamer0.10-dev libflac-dev libgpod-dev libindicate-dev libwxsqlite3-2.8-dev
这是在linux下可能的解决方案,你是windows?那我帮不了。

查看完整回答
反对 回复 2023-01-10

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信