为了账号安全,请及时绑定邮箱和手机立即绑定

编译提示错误,错误提示如下,请大家指点一下

编译提示错误,错误提示如下,请大家指点一下

子衿沉夜 2023-01-07 13:09:27

-- Could not find (the correct version of) boost.
-- MySQL currently requires boost_1_57_0

CMake Error at cmake/boost.cmake:76 (MESSAGE):
You can download it with -DDOWNLOAD_BOOST=1 -DWITH_BOOST=<directory>

This CMake script will look for boost in <directory>. If it is not there,
it will download and unpack it (in that directory) for you.

If you are inside a firewall, you may need to use an http proxy:

export http_proxy=http://example.com:80

Call Stack (most recent call first):
cmake/boost.cmake:259 (COULD_NOT_FIND_BOOST)
CMakeLists.txt:452 (INCLUDE)

-- Configuring incomplete, errors occurred!
See also "/root/mysql-5.7.7-rc/CMakeFiles/CMakeOutput.log".

查看完整描述

2 回答

?
HUH函数

TA贡献0条经验 获得超4个赞

[root@Lnmp mysql-5.7.9]# cmake \

-DCMAKE_INSTALL_PREFIX=/byrd/service/mysql-5.7.9 

-DMYSQL_DATADIR=/byrd/service/mysql-5.7.9/data 

-DMYSQL_UNIX_ADDR=/byrd/service/mysql-5.7.9/tmp/mysql.sock 

-DMYSQL_USER=mysql 

-DDEFAULT_CHARSET=utf8 

-DDEFAULT_COLLATION=utf8_general_ci 

-DENABLED_LOCAL_INFILE=ON 

-DWITH_INNOBASE_STORAGE_ENGINE=1 

-DWITH_FEDERATED_STORAGE_ENGINE=1 

-DWITH_BLACKHOLE_STORAGE_ENGINE=1 

-DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 

-DDOWNLOAD_BOOST=1 -DWITH_BOOST=/usr/local/boost

 


查看完整回答
反对 回复 2023-01-10
?
红糖糍粑

TA贡献1572条经验 获得超5个赞

错误提示里说你的计算机上没有一个可用的Boost库或版本太低,MySQL需要不低于Boost 1.57.0的版本。您应该尝试下载一个Boost,并且完成编译。

您应该会得到上面图片中的大部分文件,除了几个我自己添加的辅助编译的脚本。

完成之后请再尝试重新编译MySQL。

附注:编译后生成的二进制库保存在Boost根目录下\stage\lib中,请根据MySQL的编译步骤中的指示填写在Makefile里面或者加入环境变量(具体的我不太清楚,需要您视具体情况而定)。


查看完整回答
反对 回复 2023-01-10
  • 2 回答
  • 0 关注
  • 7 浏览

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信