为了账号安全,请及时绑定邮箱和手机立即绑定

尝试使用 pip 安装软件包时,“=”不是有效的运算符

尝试使用 pip 安装软件包时,“=”不是有效的运算符

牧羊人nacy 2023-08-22 16:33:09
我正在尝试从 .txt 文件安装一些软件包。当我尝试安装它们时,pip正在读取文件,但说'=' is an invalid operator. 我也尝试过更改'='为'=='但没有成功。例如,我尝试安装aniso8601=8.0.0=py_0,但不断收到错误:ERROR: Invalid requirement: 'aniso8601=8.0.0=py_0' (from line 4 of requirements.txt) Hint: = is not a valid operator. Did you mean == ?编辑:我从其他人那里获取了依赖项列表,而 py_0 部分是我的疏忽,因为它是他们留在列表末尾的添加内容。
查看完整描述

1 回答

?
慕斯709654

TA贡献1840条经验 获得超5个赞

我不确定你为什么这么写=py_0以及它的含义,但这是正确的需求文件的示例:


Jinja2==2.10.1

qtawesome==0.7.2

numpy==1.18.3

matplotlib==3.2.2

要安装所有依赖项,请使用pip install -r filename.txt


要创建需求文件,请使用pip freeze > filename.txt


查看完整回答
反对 回复 2023-08-22
  • 1 回答
  • 0 关注
  • 1375 浏览
慕课专栏
更多

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信