为了账号安全,请及时绑定邮箱和手机立即绑定

尝试导入已安装的 python 模块并收到错误

尝试导入已安装的 python 模块并收到错误

LEATH 2023-08-22 16:50:34
我是 python 新手,所以这可能是一个简单的修复,但我无法通过谷歌搜索找到解决方案。尝试在模块上运行导入时出现此错误。Traceback (most recent call last):  File "c:/Users/joeshmo/OneDrive - company Industries/Documents/Python/Excel Join/join.py", line 1, in <module>    from openpyxl import load_workbookModuleNotFoundError: No module named 'openpyxl'Openpyxl 已经安装,因为 pip 给了我这个......pip install openpyxl    Requirement already satisfied: openpyxl in c:\users\joeshmo\appdata\local\programs\python\python38-32\lib\site-packages (3.0.5)Requirement already satisfied: jdcal in c:\users\joeshmo\appdata\local\programs\python\python38-32\lib\site-packages (from openpyxl) (1.4.1)Requirement already satisfied: et-xmlfile in c:\users\joeshmo\appdata\local\programs\python\python38-32\lib\site-packages (from openpyxl) (1.0.1)Python安装在这里...C:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32Python路径在这里...C:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32\python38.zipC:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32\DLLsC:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32\libC:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32C:\Users\joeshmo\AppData\Roaming\Python\Python38\site-packagesC:\Users\joeshmo\AppData\Local\Programs\Python\Python38-32\lib\site-packages在 Windows 10 上。任何帮助,将不胜感激!
查看完整描述

1 回答

?
红颜莎娜

TA贡献1842条经验 获得超12个赞

在与同事进行故障排除后,我们发现我运行了 2 个版本的 python。我可以运行“py”(3.8.0)或“python”(3.8.5)。卸载旧版本后。这不再是问题了。



查看完整回答
反对 回复 2023-08-22
  • 1 回答
  • 0 关注
  • 1206 浏览
慕课专栏
更多

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信