服务端相关 / 使用 PyCharm 创建与管理项目

使用 PyCharm 创建与管理项目

在上一节我们使用 PyCharm 创建了一个简单的 demo 项目,至此,我们已经对项目有了一个初步的认知。那么,到底什么是项目?有哪些项目类型?PyCharm 支持哪些项目类型?如何使用 PyCharm 管理项目?这一节我们将详细介绍。

1. 项目(Project)概念

无论在 PyCharm 中做什么,都会在项目的上下文中执行。项目是表示完整软件解决方案的组织单位。主要作用就是起到一个项目定义、范围约束、规范类型的效果,这个概念听着有些拗口。现在我们可以简单地把项目理解为是一个单纯的目录。

2. 项目文件

当你创建一个新的项目,PyCharm 会自动生成一个 .idea 文件夹。这个文件夹的主要作用在于存放项目的控制信息,包括版本信息,历史记录等等

.idea 目录在项目视图中是不可见的的, 如果要看到 .idea 目录的内容,可以选择 “Project” 工具栏, 点击下右侧的箭头, 选择 Project Files:
图片描述

下面是 .idea 目录中的内容:

图片描述

我们分别来看下这几个文件都有哪些作用:

  • .iml 文件:描述项目结构;
  • workspace.xml 文件:包含与工作区相关的参数与选项;
  • xml 文件:每个 xml 文件负责其自己的设置集,可以通过其名称识别:projectCodeStyle.xml、encoding.xml、vcs.xml 等等。

Tips.idea 目录中的所有设置文件都应置于版本控制之下,但存储本地信息的 workspace.xml 除外。workspace.xml 文件应标记为忽略。(具体方法会在版本控制的章节详细说明)

3. 项目类型

针对不同的项目类型,PyCharm 会自动生成一系列的项目文件、库及 .idea 目录。在创建新项目的界面中,可以看到以下的项目类型,这些项目类型都是 PyCharm 所支持的:

图片描述

下面介绍主要的几种项目类型:

  • Pure Python:用于纯 Python 编程。此类项目的目录结构包含特定于 PyCharm 的设置、项目文件、库以及 .idea 目录。需要提前安装 Python,上节课我们创建的 demo 就是一个 Pure Python 项目。

  • Django:此项目类型提供 Django 应用程序的特定基础结构以及所有必要的文件和设置。使用 Django 应用程序需要数据库,IDE 已经预配置了 SQLite,如果使用其他数据库引擎,需要提前安装并配置正确。

  • Flask:此项目类型提供 Flask 应用程序的特定基础结构以及所有必要的文件和设置。

  • Google App Engine:此项目类型提供 Google 应用程序引擎应用程序的特定基础结构,以及所有必要的文件和设置。

  • 客户端项目:HTML5 Boilerplate, Bootstrap, and Foundation 都属于客户端项目。 对于客户端应用程序,PyCharm 创建特定的基础结构,并带有所需的文件和目录。

4. 创建项目

4.1 创建新项目

在 PyCharm 的主界面中依次点击: File -> New Project
图片描述

来到 Welocme to PyCharm 窗口, 选择 Create New Project

图片描述

4.2 导入项目从源文件

  1. 在 PyCharm 的主界面中依次点击: File -> Open

  2. 在打开的对话框中,选择包含所需源代码的目录;

图片描述

  1. 选定要打开的项目之后单击右下角的 “Open” 按钮;

  2. 在弹出的窗口中指定是在单独的窗口中打开新项目,还是关闭当前项目并在当前窗口打开。

图片描述

5. 管理项目

5.1 项目配置

项目配置最主要包括配置项目结构与解释器, 项目结构定义了整个项目包含文件, 解释器指定了程序运行依赖的python 环境是什么。正确的配置上述两项,才能保证程序的正常运行。具体如何配置,后续有单独的章节详细介绍。

Mac 系统依次点击:PyCharm -> Preferences
Windows and Linux 系统依次点击:File -> Settings

图片描述

Tips:有红色框中图标标记的设置仅适用于当前项目。其他设置是全局的,适用于所有现有项目。

除此以外, 不仅可以为当前项目配置设置,还可以为以后将创建的所有项目配置项目设置:File -> New Projects Settings -> Preferences for New Projects

图片描述

5.2 打开项目

可以从 Welocme to PyCharm 窗口打开项目, 可以直接选择 Open 。除此以外, PyCharm 保留最近项目的历史记录列表,您可以从左侧列表选择所需的项目打开。

图片描述

也可以通过主菜单 File -> Open Recent 打开项目。

图片描述

PyCharm 是允许同时打开多个项目的, 当你已经打开一个项目,然后再打开另外一个项目, 会有下面的弹窗。

图片描述

New Window and This Window: 每个项目都在其自己的窗口中打开。项目是独立的,不能共享信息,但剪贴板操作除外。所有项目都在同一个 PyCharm 实例中运行,并使用相同的内存空间。

Attach: 新打开的项目与已打开的窗口共享同一窗口。已打开的项目被视为主项目,并且始终首先显示在"项目"工具窗口中。所有其他项目都添加到主项目中。如图所示:

图片描述

5.3 关闭项目

通过主菜单 File -> Close Project

图片描述

当只有一个打开的项目并关闭它时,PyCharm 将显示 Welcome 界面。如果有多个项目被打开,PyCharm 只会关闭当前的项目。

另外, 如果要在一个窗口中分离已附加到主项目的任何项目,只需从"项目视图"中删除目标项目。"Project"工具窗口, 要删除项目右键单击,选择 Remove from Project View

图片描述

5.4 项目之间切换

PyCharm 是允许在不同窗口打开多个项目的,如何在多个打开项目中切换呢?使用下面的命令:

Window -> Next Project Window 
Window -> Previous Project Window 

5.5 清除缓存

PyCharm 缓存了大量文件,长时间运行下来,数据量是很大的,也比较占用系统资源。所以在某些情况下我们需要清除缓存 。例如,一个短期项目结束将来不再使用;解决某些冲突的唯一方法也是通过清除缓存。File -> Invalidate Caches/Restart

图片描述

Tips:通知缓存将在下一个启动时失效并重新生成。使用对话框中的按钮使缓存无效、重新启动 PyCharm 或两者兼而有之。

6. 小结

本小节主要介绍项目、项目文件以及项目类型的基本概念,也学习了如何创建新项目以及常用针对项目的操作。建议大家按照上面的说明与步骤实际操作一下,熟悉菜单的位置及对应的功能,并加深理解。
图片描述